Cannot run DependecyChecker tool

Nov 10, 2010 at 8:32 AM

Hi,

I'm trying to take a look at the samples that are provided from the Download section. When I run CheckDependency.cmd I have the 2 requirements ticked (Powershell and Internet Information Services 7) and all the rest are red saying to install the components above, but I know that I have them installed. How can I be able to run the samples?

Thanks,

Stefan Filip 

Coordinator
Nov 11, 2010 at 8:47 AM
Edited Nov 11, 2010 at 8:48 AM

You might need to change the execution policy in Powershell to "remoteSigned". (Check your eventlog for the exception message)

The DependencyChecker is just a convenience tool. If you know you have everything required, then just open the samples solutions with Visual Studio.

 

 

 

Nov 11, 2010 at 12:50 PM

Thanks for your answer! I have lots of exceptions generated in EventViewer by DependencyChecker. The first one is:

An exception has occured in the DependencyChecker. Message:'Windows Identity Foundation SDK' dependency could not be verified. Install components above this one first.System.Management.Automation.PSSecurityException: AuthorizationManager check failed.   at System.Management.Automation.AuthorizationManager.ShouldRunInternal(CommandInfo commandInfo, CommandOrigin origin, PSHost host)   at System.Management.Automation.CommandDiscovery.ShouldRun(ExecutionContext context, PSHost host, CommandInfo commandInfo, CommandOrigin commandOrigin)   at System.Management.Automation.CommandDiscovery.LookupCommandProcessor(CommandInfo commandInfo, CommandOrigin commandOrigin, Nullable`1 useLocalScope)   at System.Management.Automation.CommandDiscovery.LookupCommandProcessor(String commandName, CommandOrigin commandOrigin, Nullable`1 useLocalScope)   at System.Management.Automation.ExecutionContext.CreateCommand(String command)   at System.Management.Automation.CommandNode.CreateCommandProcessor(Int32& index, ExecutionContext context)   at System.Management.Automation.CommandNode.AddToPipeline(PipelineProcessor pipeline, ExecutionContext context)   at System.Management.Automation.PipelineNode.Execute(Array input, Pipe outputPipe, ArrayList& resultList, ExecutionContext context)   at System.Management.Automation.StatementListNode.ExecuteStatement(ParseTreeNode statement, Array input, Pipe outputPipe, ArrayList& resultList, ExecutionContext context)

I know I have all the tools installed and I can open the sample solutions in VS 2010. The problem is that I think the DependencyChecker tool also does some setup (like installing some certificates) and I couldn't find any guide for that. Thanks!

Coordinator
Nov 11, 2010 at 5:11 PM

The simplest would be to change the execution policy in PS to "remoteSigned" (set-executionpolicy -remotesigned), then run the DC again.

You can also run the specific PS that installs the certs. Look under "setup" folder (if I remember correctly).

Eugenio

Nov 12, 2010 at 8:14 AM

I changed the execution policy to remoteSigned and I run again DC after that, but I ran into the same issue. :(

Dec 1, 2010 at 3:03 PM

Had the same issue.

My downloaded zip file was Blocked to prevent scripts form untrusted parties. I changed it  by right-clicking Properties and then pressing the Unblock Button. I unzipped once again and then it ran for me. 

(Don't know if excecutionpolicy needs to be remoteSigned, I had it "unrestricted" due to the posts above and lots of fumbling around.)

Jørgen

Coordinator
Feb 7, 2011 at 6:48 PM

As I wrote on my blog and on the home page of this project, we are writing a new version of this guide adding a whole bunch of scenarios. We are also re-writing the Dependency Checker completely (getting rid of all PowerShells, etc) so hopefully the experience will be much improved.

Feedback always welcome!